Cyberwizzard.nl

Welcome to my world

Getting Evolution to go native on KDE4

Right now I'm trying to get Evolution to work and fill the void that the removal of KitchenSync from KDE 4.2 has caused: the possibility to synchronize your phone, PDA, calendar, contacts and email using one central point.

Installing Evolution is only the start and please note that I am running Gentoo so if you are on another linux distributions things might turn out different.

We start with the basics: when you try to install synce and you have the 'kde' use flag - it will try to pull in 'synce-kio-rapip-0.10-r1' or similar. If you are truly running KDE 4 (and ditched KDE 3 and Qt3 - like me) the ebuild will fail because it needs KDE 3. There is a new package called 'kde4-kio-rapip' (currently at version 0.2) which should work for KDE 4. I decided I don't want the deprecated KIO slaves and should I need direct access to my Windows Mobile 2003 PDA I will rather install the FUSE driver for it.

To make Evolution look like the KDE applications you need to get GTK2 to use the Qt4 engine - which will theme everything like the rest of KDE. There are 2 or 3 choices at the moment but 'x11-themes/gtk-engines-qt' is currently your best bet (at version 1.1-r1 right now).

After installing it, open up System Settings -> Appearance -> GTK Styles and Fonts and select "Use my KDE style..." and "Use my KDE fonts..." and hit apply. Now log out and back in and Firefox, Thunderbird, Evolution and any other GTK program should look like KDE applications.

The next obstacle was the fact that Evolution is missing its icons despite that the theming of the interface itself is working. This is because the normal parts of the program interface are rendered by Qt4 but the icons are not a part of the standard Qt4 theme. To fix this we need to tell GTK which native theme it should use. Not to skin the program but to provide the icons.

Unfortunately I can not figure out what is going wrong as some icons are picked up and others are not while the console of Evolution stays quiet. Running the program itself from a console shows these messages:

Bonobo-WARNING **: Could not find GNOME pixmap file (null)

Because reinstalling seems to do nothing I might try to downgrade Evolution to see if that works...